External Controls Help

All discussions here

External Controls Help

Unread postby pie8man » Sat Mar 05, 2011 12:30 am

I am in the process of setting up a timing system for point A to point B racing with one split section. I have downloaded a trial version of Xnote Stopwatch and am in the mock up stage of the process. I am running 64 bit Windows 7 on a laptop, I have a Prolific chip based USB to Serial adapter. The adapter is installed and is working as COM3. In the External controls window of XNote I have selected Com3, enable, and in the start stop window I have selected RTS-CTS but when I close the connection on pins 7 to 8 I get little to no start/stop function that is intermittent at best on the stop watch. I get absolutely no function on pins 4 to 6 for the snap.
What do you suggest I try?
pie8man
 
Posts: 8
Joined: Fri Mar 04, 2011 11:47 pm

Re: External Controls Help

Unread postby Stopwatch » Sat Mar 05, 2011 7:48 am

Send your xnsw*.ini from \Users ... AppData ...
Stopwatch
Site Admin
 
Posts: 424
Joined: Thu Feb 19, 2009 6:25 pm

Re: External Controls Help

Unread postby Stopwatch » Wed Mar 09, 2011 12:01 pm

I have run the program with your config and everything appears working out as expected. It seems hardware issues.

Also try this alternate build:
xnsw.zip
Skip triggering rebuild
(181.53 KiB) Downloaded 1152 times
Stopwatch
Site Admin
 
Posts: 424
Joined: Thu Feb 19, 2009 6:25 pm

Re: External Controls Help

Unread postby pie8man » Fri Apr 29, 2011 9:05 pm

I have my hardware issues resolved and will be testing the system at the track this weekend. Externally in version 1.62 I have the ability to start/stop, Snap as well as reset for some strange reason, it is on different post positions than is defined in the external controls dialog. Trendnet TU-S9 USB to RS-232 adapter. In any case it is working.
In another thread regarding the external control bounce time you say to change the variable in xnsw.ini to a different value;
[ExternalControl]
SkipBounce=10000
I open and change the value in the xnsw1.ini file located in User/name/appdata/roaming/xnotestopwatch, save, then go into the external control dialog box and change it to anything over 100 it goes back to 100 every time. Am I doing something wrong? I am looking for as much as a 10 second bounce delay which is 10,000 ms, correct?
pie8man
 
Posts: 8
Joined: Fri Mar 04, 2011 11:47 pm

Re: External Controls Help

Unread postby Stopwatch » Sat Apr 30, 2011 7:37 pm

pie8man wrote:I open and change the value in the xnsw1.ini file located in User/name/appdata/roaming/xnotestopwatch, save, then go into the external control dialog box and change it to anything over 100 it goes back to 100 every time. Am I doing something wrong? I am looking for as much as a 10 second bounce delay which is 10,000 ms, correct?

Debounce greater then 100ms can be set only with xnsw*.ini edit.
Stopwatch
Site Admin
 
Posts: 424
Joined: Thu Feb 19, 2009 6:25 pm

Re: External Controls Help

Unread postby pie8man » Tue May 03, 2011 3:00 am

When I set the bounce delay over 100 in the .ini file, it defaults back to 100 every time I close the software. Is there a way to keep it set where I put it?
Can you also please explain the difference between the following for the start stop settings in external control?
off-on off-on
off-on on-off
on-off on-off
on-off off-on

Thanks!!
pie8man
 
Posts: 8
Joined: Fri Mar 04, 2011 11:47 pm

Re: External Controls Help

Unread postby Stopwatch » Tue May 03, 2011 10:04 am

pie8man wrote:When I set the bounce delay over 100 in the .ini file, it defaults back to 100 every time I close the software. Is there a way to keep it set where I put it?

Do not reopen configuration window.

pie8man wrote:Can you also please explain the difference between the following for the start stop settings in external control?

Normal open/close, pulse on/off.
Stopwatch
Site Admin
 
Posts: 424
Joined: Thu Feb 19, 2009 6:25 pm

Re: External Controls Help

Unread postby pie8man » Thu May 05, 2011 7:12 pm

From the external control is there any way to automatically save results to excel or text file without a keysroke?
My scenario is this. I have Start, Snap, Snap then Reset happening from various external sensors. Is there any way on the reset command to automatically save the individual timed event to one spreadsheet and continue to add to the spreadsheet?
This is for BMX racing where we will have 40+ individual races all less than 1 minute duration.
pie8man
 
Posts: 8
Joined: Fri Mar 04, 2011 11:47 pm

Re: External Controls Help

Unread postby Stopwatch » Fri May 06, 2011 3:39 pm

pie8man wrote:Is there any way on the reset command to automatically save the individual timed event to one spreadsheet and continue to add to the spreadsheet?

Use Excel integration.
Stopwatch
Site Admin
 
Posts: 424
Joined: Thu Feb 19, 2009 6:25 pm

Re: External Controls Help

Unread postby pie8man » Tue May 10, 2011 6:26 pm

I have everything working on the desk but as soon as I put a long cable from my control panel to my photocell I get intermittent start stops,resets and snaps in no particular order. I have a few questions;
For some reason my snap external control is pins 9-8, start stop is 8-7 and reset is 8-6, basically 8 seems to be common and I have all my external control tied to 8 as common and also the appropriate pin for the command I want. First question, is that normal?
My start/stop and reset work great as intended. Snap is the issue, It works fine when I close the connection on pins 9-8 in the usb to rs-232 adapter as well as on the same terminals in the panel I built as well as with short cables (3') plugged into the panel. As soon as I plug my 50' cable in I get crazy things happening; intermittent start/ stops,resets and snaps in no particular order. I have tried an extension cord, coax and 18GA speaker wire and I get the same results. The strange thing is that when I set my multimeter to 200ohms for resistance and place the leads across the snap pins the snap control works. I am going to use a resistor that duplicates this but I was curious if you have run across this before?
In Windows XP when I change the delay skip triggering to 10,000 or anything over 100 I get an error and the Xnote will not start,how do I delay skip triggering in Windows XP?
Thanks again for all your help!!
pie8man
 
Posts: 8
Joined: Fri Mar 04, 2011 11:47 pm

Next

Return to Main forum

Who is online

Users browsing this forum: No registered users and 4 guests

cron